[development] Naming the CVS abstraction module
jpetso at gmx.at
Sat Jun 9 09:15:48 UTC 2007
On Saturday, 9. June 2007, Rob Barreca wrote:
> I like Version Control API, and think a module named
> versioncontrol.module is fine. Sure it's a bit more code, but IMO it's
> better to err on the side of being too explicit, than having people
> scratch their heads seeing vc.module.
Yes, I think that one is sensible. I'm currently drawn between
versioncontrol.module (longer code, but better name) and vcs.module
(short code, not so perfect name).
The one issue I'm still having with versioncontrol.module is its extensibility
for still longer names: there may be a vcs_project.module for the integration
with project nodes, a vcslog.module for the commit logs, and a vcsview.module
for repository browsing. (Other options left open.) Having the longer name
for the original module would probably make those extension modules' names
a bit unwieldy, and especially blow up the corresponding menu paths.
I'm still undecided. Maybe it's still better to have
"Version Control System API" and get all the subsequent advantages
in return for the crappy base name.
More information about the development