[development] Naming the CVS abstraction module

Jakob Petsovits jpetso at gmx.at
Sat Jun 9 09:32:42 UTC 2007

On Saturday, 9. June 2007, Jakob Petsovits wrote:
> The one issue I'm still having with versioncontrol.module is its
> extensibility for still longer names: there may be a vcs_project.module for
> the integration with project nodes, a vcslog.module for the commit logs,
> and a vcsview.module for repository browsing. (Other options left open.)

On second thought, we could just name the latter two "Commit Log" 
(commitlog.module) and "Repository Viewer" (repoview.module, or 
repository.module) and would be quite happy with that.

"Version Control Project integration" (vc_project.module) might not be so 
tragic as well.

In that light, I'd be fine with versioncontrol.module.


More information about the development mailing list