[development] Naming the CVS abstraction module

Victor Kane victorkane at gmail.com
Sat Jun 9 14:37:07 UTC 2007

I agree with versioncontrolapi or versioncontrol.

As a short alternative for everyone's consideration:

Repository API Module  - repoapi.module


On 6/9/07, Stefan Nagtegaal <development at robuustdesign.nl> wrote:
> Op 9-jun-2007, om 16:22 heeft Doug Green het volgende geschreven:
> > I admit I'm not the best module namer in this community, but I
> > think I've
> > learned a few things from you all.  Drupal tries very hard to use
> > descriptive names.  A big -1 for VC, VCAPI, RC, RCAPI, etc.   I like
> > versioncontrol.module or even better versioncontrolapi.
> >
> > Try avoiding unnecessary underscores in the name, because these
> > lead to
> > potential confusion with hooks.
> I have tp agree on versioncontrol.module.
> A descriptive name for a module is an absolute requirement when we
> talk about usability.
> Have a look at the support requests on drupal.org how much people
> doesn't grasp that the path.module is for the URL aliasing of nodes,
> because of it's poorly choosen name (this is still a todo on my list,
> to have that renamed to something more descriptive).
> So, imo better some larger modulename which is more descriptive, than
> s short makes-no-sense module name.
> Stefan

More information about the development mailing list