[development] sudden jquery load error

Blake Senftner bsenftner at earthlink.net
Sat Feb 5 04:03:24 UTC 2011

This is making less and less sense. 

I've rebooted my dev station (OS X) and the web server, and moved to jquery update 6.2_alpha, which loads jquery 1.3.2, and configuring that module to load the 'development' uncompressed version... now FireBug errors on jquery line 1296, claiming "reference to undefined property jQuery.cache[id][name]".

Moving to the Google Chrome browser, everything loads and runs fine with no errors. Sounds like FireFox is sick... 

Being curious, I just tried loading my project on my wife's MacBook, with fireFox & fireBug - loads with no error. Same version of FireFox & FireBug too...

bsenftner at earthlink.net

On Feb 4, 2011, at 7:18 PM, Blake Senftner wrote:

> Seems like I'm finding instances of people posting requests for help with this, but no solutions seem to accompany these posts...
> I tried installing the JQuery Update module, whose README says just install and enable, but the same jquery 1.2.6 is still being loaded... what's up with that? 
> Sincerely,
> -Blake
> bsenftner at earthlink.net
> www.BlakeSenftner.com
> On Feb 4, 2011, at 6:45 PM, Blake Senftner wrote:
>> Environment: latest D6 in WAMP on a Windows Server 2008 R2.
>> The strangest error just started occurring within firebug: The first code line of the standard Drupal jquery file (jQuery 1.2.6) is generating an error. Firebug says that line 13 has a "test for equality (==) mistyped as an assignment (=)?"
>> And because of this new, I have no idea how this could have started, bug... I am unable to continue work on a Services 3.0 based framework where I'm using java script to test the RESTful API I'm developing. (I guess I can test it with php, but I'd have to rewrite my testing framework all over.)
>> The only thing I can think that I did which could have impacted this is run cron, but that does not really make any sense...
>> I found this similar situation post http://drupal.org/node/846026?mode=2&sort=2 , but that is not the same error, but it is the same line and the same unaltered jQuery source file... has anyone else encountered this? If so, what did you do to fix it? 
>> Sincerely,
>> -Blake
>> bsenftner at earthlink.net
>> www.BlakeSenftner.com

More information about the development mailing list